Problem:
A print job fails and a user receives an error message containing “ Failed to download from S3 ...the difference between the request time and the current time is too large".
Cause:
The aforementioned error message is usually indicative of a time synchronization error wherein the Connector host’s (PC's) time is either significantly ahead or behind relative to the server in our cloud. Even a difference of a few minutes can result in these failures.
Solution:
Verify your Connector host’s system time is correct and try printing again. Better yet, you may want to configure your system with an authoritative time server to avoid such problems.
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